Saturday, December 8, 2012

Upgrade from RB750G + TP-LINK TL-WA901ND to RB2011UAS-2HnD-IN

Brought on the 7th Dec @1800hrs.
Spend next 6hrs configuring it.
Finally I get the whole idea what was bridging a network.

Sunday, September 16, 2012

Change DNS

Drop OpenDNS due to issue with l.yimg.com. There is a always a long wait or just hang loading yahoo.com and flickr.com
Using Google DNS but they are slow with some of fav site like hardwarezone.com.sg.

/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512 servers=\
    208.67.222.222,208.67.220.220,2001:470:20::2


/ip dns
set allow-remote-requests=yes cache-max-ttl=1w cache-size=2048KiB \
    max-udp-packet-size=512 servers=\
    8.8.8.8,8.8.4.4,2001:4860:4860::8888,2001:4860:4860::8844

best so far
/ip dns
set allow-remote-requests=yes max-udp-packet-size=512 servers=\
    109.69.8.34,106.186.17.181,2001:4860:4860::8888,2001:4860:4860::8844,208.67.222.222,208.67.220.220,2620:0:ccc::2,2620:0:ccd::2
 

Brother MFC7860DW

http://welcome.brother.com/sg-en/products-services/multi-function-centres/MFC7860DW.html

Finally... years of dreaming to have one...
No the best in every function but at least it's a all in one. 

Monday, June 18, 2012

Windows Home Server 2011 x64

Got a year old ASUS Eee PC 1015PEM laid around doing nothing.
Installed Windows Home Server 2011 x64.
It's much easier to setup share folder than Linux Ubuntu server 12.04.

Sunday, April 29, 2012

Upgrade

Just completed upgrading my proxy server with the following new+reused hardware to replace my testing ASUS netbook.

  • MSI E350IA-E45 with AMD E-350 Fusion Dual-Core + Radeon HD6310 Build-in Graphics Mini-ITX Motherboard E350IA-E45
  • Lian Li PC-Q18B mini-itx CASE (Black) PC-Q18 Specifications
  • G.SKILL ARES F3-1600C9D-8GAO 8GB (2x 4GB) DDR3 1600MHz CL9-9-9-24 Dual Channel F3-1600C9D-8GAO
  • reused a Vantec's ION 2 350W Power Supply
  • reused 2 WDC 80GB harddisk 
Ubuntu Desktop 12.04 LTS (ubuntu-12.04-server-amd64.iso) was loaded

Sunday, April 1, 2012

Setup Squid Proxy Server + Mikrotik RB750G


Got a year old ASUS Eee PC 1015PEM laid around doing nothing.
Download Ubuntu Server 11.10 32bit and installed on the netbook.
http://www.ubuntu.com/download/server/download

Follow the these video to have a good understanding of squid proxy setup.

Install & Configure Squid Proxy Server in Ubuntu - 1/3 Beginner 
http://youtu.be/LnBG_LEvvVw
Install & Configure Squid Proxy Server in Ubuntu - 2/3 Beginner 
http://youtu.be/gXVvmQuEiIs
Install & Configure Squid Proxy Server in Ubuntu - 3/3 Beginner 
http://youtu.be/cFgnP2FZZ_k

Connect to internet and download the squid application
sudo apt-get install squid3

Backup copy of the original squid configuration file.
sudo cp -p /etc/squid3/squid.conf /etc/squid3/squid.conf.ori

use vi to edit squid.conf
sudo vi /etc/squid3/squid.conf


 
To block websites
acl block_websites dstdomain .msn.com .yaho.com
http_access deny block_websites

View the log
sudo tail -f /var/log/squid3/access.log

After you've finished editing the configuration file, you can start Squid for the first time. First, you must create the swap directories. Do this by running Squid with the -z option:

sudo /etc/init.d/squid3 stop
sudo mkdir /squid_cache
sudo chown -R proxy:proxy /squid_cache


sudo squid3 -z

sudo /etc/init.d/squid3 start



Once that completes, you can start Squid and try it out. Probably the best thing to do is run it from your terminal and watch the debugging output. Use this command:

sudo squid3 -NCd1

If everything is working fine, then your console displays: "Ready to serve requests".
Squid service command
sudo service squid3 stop,status,start,restart
sudo pkill -9 squid

Mikrotik firewall rule
/ip firewall nat add action=dst-nat chain=dstnat disabled=no dst-port=80 in-interface=ether2-local-master protocol=tcp to-addresses=192.168.3.100 to-ports=3128

https setup (1)

https_port 3129 transparent key=/etc/squid3/ssl/squid3.key cert=/etc/squid3/ssl/squid3.crt
 
sudo mkdir /etc/squid3/ssl
cd /etc/squid3/ssl/
sudo openssl genrsa -des3 -out squid3.key 1024
sudo openssl req -new -key squid3.key -out squid3.csr
sudo cp -p squid3.key squid3.key.org
sudo openssl rsa -in squid3.key.org -out squid3.key
sudo openssl x509 -req -days 365 -in squid3.csr -signkey squid3.key -out squid3.crt
 
https setup (2) 
openssl req -new -newkey rsa:1024 -days 365 -nodes -x509 -keyout myCA.pem  -out myCA.pem
openssl x509 -in myCA.pem -outform DER -out myCA.der 
 

 To use the Malware Block List on a Squid proxy to block user access to URLs that contain Malware you need to perform the following simple steps:

* Download the block list:
      wget -O - http://malware.hiperlinks.com.br/cgi/submit?action=list_squid > malware_block_list.txt

* Create an ACL in the main configuration file (squid.conf) pointing to a file which will have the list URLs:
      acl malware_block_list url_regex -i "/etc/squid/malware_block_list.txt"

* Enable the ACL created previously:
      http_access deny malware_block_list
      deny_info http://malware.hiperlinks.com.br/denied.shtml malware_block_list

* Force Squid reconfiguration:
      squid -k reconfigure
 
 awk '!/^\ *#/&&(length > 0)' /etc/squid3/squid.conf